Use After Free Affecting libsass package, versions <3.5.5-3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.04% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-LIBSASS-296012
  • published3 Dec 2018
  • disclosed3 Dec 2018

Introduced: 3 Dec 2018

CVE-2018-19827  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:10 libsass to version 3.5.5-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsass package and not the libsass package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

In LibSass 3.5.5, a use-after-free vulnerability exists in the SharedPtr class in SharedPtr.cpp (or SharedPtr.hpp) that may cause a denial of service (application crash) or possibly have unspecified other impact.