Memory Leak Affecting libsdl2 package, versions <2.0.9+dfsg1-1+deb10u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.32% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-LIBSDL2-3229278
  • published13 Jan 2023
  • disclosed12 Jan 2023

Introduced: 12 Jan 2023

CVE-2022-4743  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Debian:10 libsdl2 to version 2.0.9+dfsg1-1+deb10u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsdl2 package and not the libsdl2 package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

A potential memory leak issue was discovered in SDL2 in GLES_CreateTexture() function in SDL_render_gles.c. The vulnerability allows an attacker to cause a denial of service attack. The vulnerability affects SDL2 v2.0.4 and above. SDL-1.x are not affected.

CVSS Base Scores

version 3.1