Out-of-bounds Read Affecting libssh2 package, versions *


low

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Availability High
Expand this section
Red Hat
6.8 medium
Expand this section
NVD
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-LIBSSH2-452460
  • published 24 Jul 2019
  • disclosed 16 Jul 2019

How to fix?

There is no fixed version for Debian:10 libssh2.

NVD Description

Note: Versions mentioned in the description apply to the upstream libssh2 package.

In libssh2 before 1.9.0, kex_method_diffie_hellman_group_exchange_sha256_key_exchange in kex.c has an integer overflow that could lead to an out-of-bounds read in the way packets are read from the server. A remote attacker who compromises a SSH server may be able to disclose sensitive information or cause a denial of service condition on the client system when a user connects to the server. This is related to an _libssh2_check_length mistake, and is different from the various issues fixed in 1.8.1, such as CVE-2019-3855.