Improper Access Control Affecting libusbmuxd package, versions <1.0.10-3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.99% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-LIBUSBMUXD-317898
  • published13 Jun 2016
  • disclosed13 Jun 2016

Introduced: 13 Jun 2016

CVE-2016-5104  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade Debian:10 libusbmuxd to version 1.0.10-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libusbmuxd package and not the libusbmuxd package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

The socket_create function in common/socket.c in libimobiledevice and libusbmuxd allows remote attackers to bypass intended access restrictions and communicate with services on iOS devices by connecting to an IPv4 TCP socket.

CVSS Base Scores

version 3.1