Out-of-Bounds Affecting linux-5.10 package, versions <5.10.149-2~deb10u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.13% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-LINUX510-3091166
  • published23 Oct 2022
  • disclosed21 Oct 2022

Introduced: 21 Oct 2022

CVE-2022-3649  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:10 linux-5.10 to version 5.10.149-2~deb10u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-5.10 package and not the linux-5.10 package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

A vulnerability was found in Linux Kernel. It has been classified as problematic. Affected is the function nilfs_new_inode of the file fs/nilfs2/inode.c of the component BPF. The manipulation leads to use after free. It is possible to launch the attack remotely. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-211992.

CVSS Base Scores

version 3.1