OS Command Injection Affecting mariadb-10.3 package, versions <1:10.3.29-0+deb10u1


0.0
high

Snyk CVSS

    Attack Complexity Low
    Privileges Required High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    Exploit Maturity Mature
    EPSS 2.14% (89th percentile)
Expand this section
NVD
7.2 high
Expand this section
SUSE
7.2 high
Expand this section
Red Hat
7.2 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-MARIADB103-1087462
  • published 19 Mar 2021
  • disclosed 19 Mar 2021

How to fix?

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.29-0+deb10u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mariadb-10.3 package and not the mariadb-10.3 package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

A remote code execution issue was discovered in MariaDB 10.2 before 10.2.37, 10.3 before 10.3.28, 10.4 before 10.4.18, and 10.5 before 10.5.9; Percona Server through 2021-03-03; and the wsrep patch through 2021-03-03 for MySQL. An untrusted search path leads to eval injection, in which a database SUPER user can execute OS commands after modifying wsrep_provider and wsrep_notify_cmd. NOTE: this does not affect an Oracle product.