CVE-2023-26314 Affecting mono package, versions <5.18.0.240+dfsg-3+deb10u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.98% (62nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-MONO-3329419
  • published22 Feb 2023
  • disclosed22 Feb 2023

Introduced: 22 Feb 2023

CVE-2023-26314  (opens in a new tab)

How to fix?

Upgrade Debian:10 mono to version 5.18.0.240+dfsg-3+deb10u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mono package and not the mono package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

The mono package before 6.8.0.105+dfsg-3.3 for Debian allows arbitrary code execution because the application/x-ms-dos-executable MIME type is associated with an un-sandboxed Mono CLR interpreter.

CVSS Base Scores

version 3.1