Use After Free Affecting nasm package, versions <2.13.02-0.1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.41% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-NASM-371439
  • published21 Dec 2017
  • disclosed21 Dec 2017

Introduced: 21 Dec 2017

CVE-2017-17817  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:10 nasm to version 2.13.02-0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nasm package and not the nasm package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

In Netwide Assembler (NASM) 2.14rc0, there is a use-after-free in pp_verror in asm/preproc.c that will cause a remote denial of service attack.