Improper Input Validation Affecting node-pathval package, versions <1.1.0-3+deb10u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.52% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-NODEPATHVAL-1021914
  • published26 Oct 2020
  • disclosed26 Oct 2020

Introduced: 26 Oct 2020

CVE-2020-7751  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:10 node-pathval to version 1.1.0-3+deb10u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-pathval package and not the node-pathval package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

pathval before version 1.1.1 is vulnerable to prototype pollution.

CVSS Base Scores

version 3.1