Improper Authentication Affecting octavia package, versions <3.0.0-3+deb10u1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.32% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-OCTAVIA-471964
  • published7 Oct 2019
  • disclosed8 Oct 2019

Introduced: 7 Oct 2019

CVE-2019-17134  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Debian:10 octavia to version 3.0.0-3+deb10u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream octavia package and not the octavia package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

Amphora Images in OpenStack Octavia >=0.10.0 <2.1.2, >=3.0.0 <3.2.0, >=4.0.0 <4.1.0 allows anyone with access to the management network to bypass client-certificate based authentication and retrieve information or issue configuration commands via simple HTTP requests to the Agent on port https/9443, because the cmd/agent.py gunicorn cert_reqs option is True but is supposed to be ssl.CERT_REQUIRED.

CVSS Base Scores

version 3.1