Numeric Errors Affecting openldap package, versions <2.4.39-1.1


low

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
NVD  medium
Red Hat  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-OPENLDAP-304626
  • published 5 Feb 2014
  • disclosed 5 Feb 2014

How to fix?

Upgrade Debian:10 openldap to version 2.4.39-1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See How to fix? for Debian:10 relevant versions.

The rwm overlay in OpenLDAP 2.4.23, 2.4.36, and earlier does not properly count references, which allows remote attackers to cause a denial of service (slapd crash) by unbinding immediately after a search request, which triggers rwm_conn_destroy to free the session context while it is being used by rwm_op_search.