openldap vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the openldap package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • C
SQL Injection

<2.4.47+dfsg-3+deb10u7
  • H
Reachable Assertion

<2.4.47+dfsg-3+deb10u6
  • H
Reachable Assertion

<2.4.47+dfsg-3+deb10u5
  • H
Access of Resource Using Incompatible Type ('Type Confusion')

<2.4.47+dfsg-3+deb10u5
  • H
Integer Underflow

<2.4.47+dfsg-3+deb10u5
  • H
Loop with Unreachable Exit Condition ('Infinite Loop')

<2.4.47+dfsg-3+deb10u5
  • H
Release of Invalid Pointer or Reference

<2.4.47+dfsg-3+deb10u5
  • H
CVE-2020-36226

<2.4.47+dfsg-3+deb10u5
  • H
Double Free

<2.4.47+dfsg-3+deb10u5
  • H
Out-of-bounds Read

<2.4.47+dfsg-3+deb10u5
  • H
Reachable Assertion

<2.4.47+dfsg-3+deb10u5
  • H
Integer Underflow

<2.4.47+dfsg-3+deb10u5
  • H
Reachable Assertion

<2.4.47+dfsg-3+deb10u4
  • H
Reachable Assertion

<2.4.47+dfsg-3+deb10u4
  • H
NULL Pointer Dereference

<2.4.47+dfsg-3+deb10u3
  • L
Improper Certificate Validation

*
  • H
Uncontrolled Recursion

<2.4.47+dfsg-3+deb10u2
  • M
CVE-2019-13057

<2.4.47+dfsg-3+deb10u1
  • H
CVE-2019-13565

<2.4.47+dfsg-3+deb10u1
  • L
Out-of-Bounds

*
  • L
Improper Initialization

*
  • M
Double Free

<2.4.44+dfsg-5
  • L
Cryptographic Issues

*
  • M
Improper Input Validation

<2.4.42+dfsg-2
  • M
Access Restriction Bypass

<2.4.40-2
  • M
CVE-2015-1546

<2.4.40-4
  • M
CVE-2015-1545

<2.4.40-4
  • L
Numeric Errors

<2.4.39-1.1
  • L
Out-of-Bounds

<2.4.31-1
  • L
Numeric Errors

<2.4.28-1
  • L
Resource Management Errors

<2.4.25-1
  • L
Improper Authentication

<2.4.25-1
  • L
Access Restriction Bypass

<2.4.25-1
  • M
Access Restriction Bypass

<2.4.23-1
  • M
Access Restriction Bypass

<2.4.23-1
  • L
Improper Certificate Validation

<2.4.17-2.1
  • L
Resource Management Errors

<2.4.10-3