CVE-2019-13565 Affecting openldap package, versions <2.4.47+dfsg-3+deb10u1


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
NVD
7.5 high
Expand this section
SUSE
6.5 medium
Expand this section
Red Hat
7.4 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-OPENLDAP-455359
  • published 24 Jul 2019
  • disclosed 26 Jul 2019

How to fix?

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See How to fix? for Debian:10 relevant versions.

An issue was discovered in OpenLDAP 2.x before 2.4.48. When using SASL authentication and session encryption, and relying on the SASL security layers in slapd access controls, it is possible to obtain access that would otherwise be denied via a simple bind for any identity covered in those ACLs. After the first SASL bind is completed, the sasl_ssf value is retained for all new non-SASL connections. Depending on the ACL configuration, this can affect different types of operations (searches, modifications, etc.). In other words, a successful authorization step completed by one user affects the authorization requirement for a different user.