Improper Authentication Affecting openldap package, versions <2.4.25-1


low

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
NVD  medium
Red Hat  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-OPENLDAP-304676
  • published 20 Mar 2011
  • disclosed 20 Mar 2011

How to fix?

Upgrade Debian:10 openldap to version 2.4.25-1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See How to fix? for Debian:10 relevant versions.

bind.cpp in back-ndb in OpenLDAP 2.4.x before 2.4.24 does not require authentication for the root Distinguished Name (DN), which allows remote attackers to bypass intended access restrictions via an arbitrary password.