Resource Exhaustion Affecting openldap package, versions <2.4.47+dfsg-3+deb10u2


0.0
high

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
NVD
7.5 high
Expand this section
Red Hat
7.5 high
Expand this section
SUSE
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-OPENLDAP-567776
  • published 28 Apr 2020
  • disclosed 28 Apr 2020

How to fix?

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openldap package and not the openldap package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

In filter.c in slapd in OpenLDAP before 2.4.50, LDAP search filters with nested boolean expressions can result in denial of service (daemon crash).