CVE-2020-36226 Affecting openldap package, versions <2.4.47+dfsg-3+deb10u5



    Attack Complexity Low
    Availability High
Expand this section
7.5 high
Expand this section
Red Hat
7.5 high
Expand this section
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-OPENLDAP-1064744
  • published 26 Jan 2021
  • disclosed 26 Jan 2021

How to fix?

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u5 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See How to fix? for Debian:10 relevant versions.

A flaw was discovered in OpenLDAP before 2.4.57 leading to a memch->bv_len miscalculation and slapd crash in the saslAuthzTo processing, resulting in denial of service.