CVE-2015-1545 Affecting openldap package, versions <2.4.40-4


0.0
medium

Snyk CVSS

    Attack Complexity Low
NVD
CVSS v3 N/A  medium
Red Hat
CVSS v3 N/A  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-OPENLDAP-304611
  • published 12 Feb 2015
  • disclosed 12 Feb 2015

How to fix?

Upgrade Debian:10 openldap to version 2.4.40-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openldap package and not the openldap package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

The deref_parseCtrl function in servers/slapd/overlays/deref.c in OpenLDAP 2.4.13 through 2.4.40 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via an empty attribute list in a deref control in a search request.