Improper Certificate Validation Affecting openldap package, versions *


low

Snyk CVSS

    Attack Complexity High
    User Interaction Required
Expand this section
NVD
4.2 medium
Expand this section
SUSE
4.2 medium
Expand this section
Red Hat
4.2 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-OPENLDAP-584924
  • published 16 Jul 2020
  • disclosed 14 Jul 2020

How to fix?

There is no fixed version for Debian:10 openldap.

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package.

libldap in certain third-party OpenLDAP packages has a certificate-validation flaw when the third-party package is asserting RFC6125 support. It considers CN even when there is a non-matching subjectAltName (SAN). This is fixed in, for example, openldap-2.4.46-10.el8 in Red Hat Enterprise Linux.