Resource Management Errors Affecting openldap package, versions <2.4.25-1


low

Snyk CVSS

    Attack Complexity Low
NVD
CVSS v3 N/A  medium
Red Hat
CVSS v3 N/A  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-OPENLDAP-304662
  • published 20 Mar 2011
  • disclosed 20 Mar 2011

How to fix?

Upgrade Debian:10 openldap to version 2.4.25-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openldap package and not the openldap package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

modrdn.c in slapd in OpenLDAP 2.4.x before 2.4.24 allows remote attackers to cause a denial of service (daemon crash) via a relative Distinguished Name (DN) modification request (aka MODRDN operation) that contains an empty value for the OldDN field.