Access Restriction Bypass Affecting openldap package, versions <2.4.23-1


0.0
medium

Snyk CVSS

    Attack Complexity Low
NVD
CVSS v3 N/A  medium
Red Hat
CVSS v3 N/A  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-OPENLDAP-304671
  • published 28 Jul 2010
  • disclosed 28 Jul 2010

How to fix?

Upgrade Debian:10 openldap to version 2.4.23-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openldap package and not the openldap package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

OpenLDAP 2.4.22 allows remote attackers to cause a denial of service (crash) via a modrdn call with a zero-length RDN destination string, which is not properly handled by the smr_normalize function and triggers a NULL pointer dereference in the IA5StringNormalize function in schema_init.c, as demonstrated using the Codenomicon LDAPv3 test suite.