Cryptographic Issues Affecting openldap package, versions *


low
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DEBIAN10-OPENLDAP-304654

  • published

    7 Dec 2015

  • disclosed

    7 Dec 2015

How to fix?

There is no fixed version for Debian:10 openldap.

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package.

The nss_parse_ciphers function in libraries/libldap/tls_m.c in OpenLDAP does not properly parse OpenSSL-style multi-keyword mode cipher strings, which might cause a weaker than intended cipher to be used and allow remote attackers to have unspecified impact via unknown vectors.