Integer Overflow or Wraparound Affecting openssl package, versions <1.1.1d-0+deb10u5


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
RHEL
4.8 medium
Expand this section
NVD
5.3 medium
Expand this section
SUSE
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-OPENSSL-536856
  • published 6 Dec 2019
  • disclosed 6 Dec 2019

How to fix?

Upgrade Debian:10 openssl to version 1.1.1d-0+deb10u5 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream openssl package. See How to fix? for Debian:10 relevant versions.

There is an overflow bug in the x64_64 Montgomery squaring procedure used in exponentiation with 512-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against 2-prime RSA1024, 3-prime RSA1536, and DSA1024 as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH512 are considered just feasible. However, for an attack the target would have to re-use the DH512 private key, which is not recommended anyway. Also applications directly using the low level API BN_mod_exp may be affected if they use BN_FLG_CONSTTIME. Fixed in OpenSSL 1.1.1e (Affected 1.1.1-1.1.1d). Fixed in OpenSSL 1.0.2u (Affected 1.0.2-1.0.2t).