Out-of-bounds Read Affecting p11-kit package, versions <0.23.15-2+deb10u1


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
Red Hat
5.3 medium
Expand this section
NVD
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-P11KIT-1050832
  • published 13 Dec 2020
  • disclosed 16 Dec 2020

How to fix?

Upgrade Debian:10 p11-kit to version 0.23.15-2+deb10u1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream p11-kit package. See How to fix? for Debian:10 relevant versions.

An issue was discovered in p11-kit 0.21.1 through 0.23.21. A heap-based buffer over-read has been discovered in the RPC protocol used by thep11-kit server/remote commands and the client library. When the remote entity supplies a byte array through a serialized PKCS#11 function call, the receiving entity may allow the reading of up to 4 bytes of memory past the heap allocation.