Integer Overflow or Wraparound Affecting p11-kit package, versions <0.23.15-2+deb10u1


0.0
high

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
SUSE
7.5 high
Expand this section
NVD
7.5 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-P11KIT-1050836
  • published 13 Dec 2020
  • disclosed 16 Dec 2020

How to fix?

Upgrade Debian:10 p11-kit to version 0.23.15-2+deb10u1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream p11-kit package. See How to fix? for Debian:10 relevant versions.

An issue was discovered in p11-kit 0.21.1 through 0.23.21. Multiple integer overflows have been discovered in the array allocations in the p11-kit library and the p11-kit list command, where overflow checks are missing before calling realloc or calloc.