Out-of-Bounds Affecting pcre2 package, versions <10.22-3


0.0
high

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
NVD
7.5 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-PCRE2-326068
  • published 20 Mar 2017
  • disclosed 20 Mar 2017

How to fix?

Upgrade Debian:10 pcre2 to version 10.22-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcre2 package and not the pcre2 package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

libpcre1 in PCRE 8.40 and libpcre2 in PCRE2 10.23 allow remote attackers to cause a denial of service (segmentation violation for read access, and application crash) by triggering an invalid Unicode property lookup.