Information Exposure Affecting pcre3 package, versions <2:8.38-1


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-PCRE3-345447
  • published 2 Dec 2015
  • disclosed 2 Dec 2015

How to fix?

Upgrade Debian:10 pcre3 to version 2:8.38-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcre3 package and not the pcre3 package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

pcregrep in PCRE before 8.38 mishandles the -q option for binary files, which might allow remote attackers to obtain sensitive information via a crafted file, as demonstrated by a CGI script that sends stdout data to a client.