Numeric Errors Affecting pcre3 package, versions <7.3-1


0.0
high

Snyk CVSS

    Attack Complexity Low
NVD
CVSS v3 N/A  high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-PCRE3-345482
  • published 7 Nov 2007
  • disclosed 7 Nov 2007

How to fix?

Upgrade Debian:10 pcre3 to version 7.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcre3 package and not the pcre3 package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

Multiple integer overflows in Perl-Compatible Regular Expression (PCRE) library before 7.3 allow context-dependent attackers to cause a denial of service (crash) or execute arbitrary code via unspecified escape (backslash) sequences.