Numeric Errors Affecting pcre3 package, versions <6.2-1


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
NVD  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-PCRE3-345498
  • published 14 Nov 2007
  • disclosed 14 Nov 2007

How to fix?

Upgrade Debian:10 pcre3 to version 6.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcre3 package and not the pcre3 package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

Integer overflow in Perl-Compatible Regular Expression (PCRE) library before 6.7 might allow context-dependent attackers to execute arbitrary code via a regular expression that involves large (1) min, (2) max, or (3) duplength values that cause an incorrect length calculation and trigger a buffer overflow, a different vulnerability than CVE-2006-7227. NOTE: this issue was originally subsumed by CVE-2006-7224, but that CVE has been REJECTED and split.