Directory Traversal Affecting pcs package, versions <0.9.164-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.06% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-PCS-317669
  • published12 Apr 2018
  • disclosed12 Apr 2018

Introduced: 12 Apr 2018

CVE-2018-1079  (opens in a new tab)
CWE-22  (opens in a new tab)
CWE-552  (opens in a new tab)

How to fix?

Upgrade Debian:10 pcs to version 0.9.164-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcs package and not the pcs package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

pcs before version 0.9.164 and 0.10 is vulnerable to a privilege escalation via authorized user malicious REST call. The REST interface of the pcsd service did not properly sanitize the file name from the /remote/put_file query. If the /etc/booth directory exists, an authenticated attacker with write permissions could create or overwrite arbitrary files with arbitrary data outside of the /etc/booth directory, in the context of the pcsd process.