Interpretation Conflict Affecting ruby2.5 package, versions *



    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
8.8 high
Expand this section
Red Hat
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-RUBY25-3148068
  • published 25 Nov 2022
  • disclosed 18 Nov 2022

How to fix?

There is no fixed version for Debian:10 ruby2.5.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.5 package and not the ruby2.5 package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

The cgi gem before, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTTP response or to create a CGI::Cookie object.