Improper Input Validation Affecting ruby-mail package, versions <2.4.4-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.47% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-RUBYMAIL-384501
  • published18 Jul 2012
  • disclosed18 Jul 2012

Introduced: 18 Jul 2012

CVE-2012-2140  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:10 ruby-mail to version 2.4.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-mail package and not the ruby-mail package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

The Mail gem before 2.4.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a (1) sendmail or (2) exim delivery.

CVSS Base Scores

version 3.1