Incorrect Authorization Affecting screen package, versions <4.5.0-3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.09% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-SCREEN-315780
  • published20 Mar 2017
  • disclosed20 Mar 2017

Introduced: 20 Mar 2017

CVE-2017-5618  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Debian:10 screen to version 4.5.0-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream screen package and not the screen package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

GNU screen before 4.5.1 allows local users to modify arbitrary files and consequently gain root privileges by leveraging improper checking of logfile permissions.