Out-of-bounds Write Affecting slirp4netns package, versions <0.2.1-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.61% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-SLIRP4NETNS-259555
  • published29 Jan 2019
  • disclosed21 Mar 2019

Introduced: 29 Jan 2019

CVE-2019-6778  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:10 slirp4netns to version 0.2.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slirp4netns package and not the slirp4netns package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

In QEMU 3.0.0, tcp_emu in slirp/tcp_subr.c has a heap-based buffer overflow.