Insecure Storage of Sensitive Information Affecting slurm-llnl package, versions <18.08.5.2-1+deb10u2


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.83% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-SLURMLLNL-1040340
  • published14 Nov 2020
  • disclosed27 Nov 2020

Introduced: 14 Nov 2020

CVE-2020-27746  (opens in a new tab)
CWE-922  (opens in a new tab)

How to fix?

Upgrade Debian:10 slurm-llnl to version 18.08.5.2-1+deb10u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-llnl package and not the slurm-llnl package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

Slurm before 19.05.8 and 20.x before 20.02.6 exposes Sensitive Information to an Unauthorized Actor because xauth for X11 magic cookies is affected by a race condition in a read operation on the /proc filesystem.

CVSS Base Scores

version 3.1