SQL Injection Affecting slurm-llnl package, versions <17.11.5-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.88% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-SLURMLLNL-299799
  • published15 Mar 2018
  • disclosed15 Mar 2018

Introduced: 15 Mar 2018

CVE-2018-7033  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade Debian:10 slurm-llnl to version 17.11.5-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-llnl package and not the slurm-llnl package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

SchedMD Slurm before 17.02.10 and 17.11.x before 17.11.5 allows SQL Injection attacks against SlurmDBD.