Buffer Overflow Affecting sniproxy package, versions <0.6.0-1+deb10u1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
65.75% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-SNIPROXY-5351872
  • published31 Mar 2023
  • disclosed30 Mar 2023

Introduced: 30 Mar 2023

CVE-2023-25076  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Debian:10 sniproxy to version 0.6.0-1+deb10u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sniproxy package and not the sniproxy package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

A buffer overflow vulnerability exists in the handling of wildcard backend hosts of SNIProxy 0.6.0-2 and the master branch (commit: 822bb80df9b7b345cc9eba55df74a07b498819ba). A specially crafted HTTP or TLS packet can lead to arbitrary code execution. An attacker could send a malicious packet to trigger this vulnerability.

CVSS Base Scores

version 3.1