Improper Input Validation Affecting cfrpki package, versions <1.4.2-1~deb11u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.21% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-CFRPKI-1920681
  • published12 Nov 2021
  • disclosed11 Nov 2021

Introduced: 11 Nov 2021

CVE-2021-3910  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:11 cfrpki to version 1.4.2-1~deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cfrpki package and not the cfrpki package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

OctoRPKI crashes when encountering a repository that returns an invalid ROA (just an encoded NUL (\0) character).

CVSS Base Scores

version 3.1