Insufficiently Protected Credentials Affecting curl package, versions <7.74.0-1.3+deb11u2


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
Expand this section
NVD
5.7 medium
Expand this section
Red Hat
5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-CURL-2804158
  • published 27 Apr 2022
  • disclosed 2 Jun 2022

How to fix?

Upgrade Debian:11 curl to version 7.74.0-1.3+deb11u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

An insufficiently protected credentials vulnerability exists in curl 4.9 to and include curl 7.82.0 are affected that could allow an attacker to extract credentials when follows HTTP(S) redirects is used with authentication could leak credentials to other services that exist on different protocols or port numbers.