Out-of-bounds Write Affecting curl package, versions <7.74.0-1.3+deb11u2


0.0
medium

Snyk CVSS

    Attack Complexity High
    Confidentiality High
Expand this section
NVD
5.9 medium
Expand this section
Red Hat
5.3 medium
Expand this section
SUSE
6.6 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-CURL-2936232
  • published 28 Jun 2022
  • disclosed 7 Jul 2022

How to fix?

Upgrade Debian:11 curl to version 7.74.0-1.3+deb11u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

When curl < 7.84.0 does FTP transfers secured by krb5, it handles message verification failures wrongly. This flaw makes it possible for a Man-In-The-Middle attack to go unnoticed and even allows it to inject data to the client.