Attack Complexity High
EPSS 1.19% (84th percentile)
Do your applications use this vulnerable package?
In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.Test your applications
- Snyk ID SNYK-DEBIAN11-CURL-516153
- published 23 Apr 2018
- disclosed 23 Apr 2018
Introduced: 23 Apr 2018CVE-2016-9586 Open this link in a new tab
CWE-122 Open this link in a new tab
How to fix?
curl to version 7.52.1-1 or higher.
Note: Versions mentioned in the description apply only to the upstream
curl package and not the
curl package as distributed by
How to fix? for
Debian:11 relevant fixed versions and status.
curl before version 7.52.0 is vulnerable to a buffer overflow when doing a large floating point output in libcurl's implementation of the printf() functions. If there are any application that accepts a format string from the outside without necessary input filtering, it could allow remote attacks.