Improper Input Validation Affecting curl package, versions <7.43.0-1



    Attack Complexity Low

    Threat Intelligence

    EPSS 0.98% (82nd percentile)
Expand this section
6.5 medium
Expand this section
Red Hat
5.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-CURL-516763
  • published 22 Jun 2015
  • disclosed 22 Jun 2015

How to fix?

Upgrade Debian:11 curl to version 7.43.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

The smb_request_state function in cURL and libcurl 7.40.0 through 7.42.1 allows remote SMB servers to obtain sensitive information from memory or cause a denial of service (out-of-bounds read and crash) via crafted length and offset values.