Cryptographic Issues Affecting curl package, versions <7.38.0-1



    Attack Complexity Low

    Threat Intelligence

    EPSS 0.55% (75th percentile)
Expand this section
5.3 medium
Expand this section
Red Hat
4.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-CURL-520466
  • published 18 Nov 2014
  • disclosed 18 Nov 2014

How to fix?

Upgrade Debian:11 curl to version 7.38.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

cURL and libcurl before 7.38.0 allow remote attackers to bypass the Same Origin Policy and set cookies for arbitrary sites by setting a cookie for a top-level domain.