Improper Input Validation Affecting curl package, versions <7.34.0-1



    Attack Complexity High

    Threat Intelligence

    EPSS 0.25% (62nd percentile)
Expand this section
4.8 medium
Expand this section
Red Hat
3.7 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-CURL-523115
  • published 23 Dec 2013
  • disclosed 23 Dec 2013

How to fix?

Upgrade Debian:11 curl to version 7.34.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

The GnuTLS backend in libcurl 7.21.4 through 7.33.0, when disabling digital signature verification (CURLOPT_SSL_VERIFYPEER), also disables the CURLOPT_SSL_VERIFYHOST check for CN or SAN host name fields, which makes it easier for remote attackers to spoof servers and conduct man-in-the-middle (MITM) attacks.