Improper Authentication Affecting curl package, versions <7.47.0-1



    Attack Complexity Low

    Threat Intelligence

    EPSS 1.7% (86th percentile)
Expand this section
7.3 high
Expand this section
Red Hat
4.8 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-CURL-526315
  • published 29 Jan 2016
  • disclosed 29 Jan 2016

How to fix?

Upgrade Debian:11 curl to version 7.47.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

The ConnectionExists function in lib/url.c in libcurl before 7.47.0 does not properly re-use NTLM-authenticated proxy connections, which might allow remote attackers to authenticate as other users via a request, a similar issue to CVE-2014-0015.