Improper Authentication Affecting curl package, versions <7.35.0-1



    Attack Complexity High

    Threat Intelligence

    EPSS 0.73% (79th percentile)
Expand this section
4.8 medium
Expand this section
Red Hat
4.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-CURL-528463
  • published 2 Feb 2014
  • disclosed 2 Feb 2014

How to fix?

Upgrade Debian:11 curl to version 7.35.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

cURL and libcurl 7.10.6 through 7.34.0, when more than one authentication method is enabled, re-uses NTLM connections, which might allow context-dependent attackers to authenticate as other users via a request.