Access Restriction Bypass Affecting curl package, versions <7.42.0-1



    Attack Complexity Low

    Threat Intelligence

    EPSS 1.33% (85th percentile)
Expand this section
5.3 medium
Expand this section
Red Hat
4.8 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-CURL-529456
  • published 24 Apr 2015
  • disclosed 24 Apr 2015

How to fix?

Upgrade Debian:11 curl to version 7.42.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

cURL and libcurl 7.10.6 through 7.41.0 does not properly re-use NTLM connections, which allows remote attackers to connect as other users via an unauthenticated request, a similar issue to CVE-2014-0015.