Attack Complexity Low
EPSS 1.13% (83rd percentile)
Do your applications use this vulnerable package?
In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.Test your applications
- Snyk ID SNYK-DEBIAN11-CURL-530314
- published 2 Dec 2018
- disclosed 31 Oct 2018
Introduced: 31 Oct 2018CVE-2018-16842 Open this link in a new tab
CWE-125 Open this link in a new tab
How to fix?
curl to version 7.62.0-1 or higher.
Note: Versions mentioned in the description apply only to the upstream
curl package and not the
curl package as distributed by
How to fix? for
Debian:11 relevant fixed versions and status.
Curl versions 7.14.1 through 7.61.1 are vulnerable to a heap-based buffer over-read in the tool_msgs.c:voutf() function that may result in information exposure and denial of service.