Out-of-bounds Read Affecting curl package, versions <7.62.0-1



    Attack Complexity Low
    Confidentiality High
    Availability High

    Threat Intelligence

    EPSS 1.13% (83rd percentile)
Expand this section
9.1 critical
Expand this section
4.4 medium
Expand this section
Red Hat
3.6 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-CURL-530314
  • published 2 Dec 2018
  • disclosed 31 Oct 2018

How to fix?

Upgrade Debian:11 curl to version 7.62.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

Curl versions 7.14.1 through 7.61.1 are vulnerable to a heap-based buffer over-read in the tool_msgs.c:voutf() function that may result in information exposure and denial of service.