Cross-site Request Forgery (CSRF) Affecting deluge package, versions <1.3.13+git20161130.48cedf63-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.02% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-DELUGE-529144
  • published18 Mar 2017
  • disclosed18 Mar 2017

Introduced: 18 Mar 2017

CVE-2017-7178  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade Debian:11 deluge to version 1.3.13+git20161130.48cedf63-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream deluge package and not the deluge package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

CSRF was discovered in the web UI in Deluge before 1.3.14. The exploitation methodology involves (1) hosting a crafted plugin that executes an arbitrary program from its init.py file and (2) causing the victim to download, install, and enable this plugin.

CVSS Base Scores

version 3.1