Arbitrary Command Injection Affecting devscripts package, versions <2.15.7


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.53% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-DEVSCRIPTS-515679
  • published25 Sept 2017
  • disclosed25 Sept 2017

Introduced: 25 Sep 2017

CVE-2015-5704  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade Debian:11 devscripts to version 2.15.7 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream devscripts package and not the devscripts package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

scripts/licensecheck.pl in devscripts before 2.15.7 allows local users to execute arbitrary shell commands.