CVE-2003-0021 Affecting eterm package, versions <0.9.2-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.21% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-ETERM-530009
  • published3 Mar 2003
  • disclosed3 Mar 2003

Introduced: 3 Mar 2003

CVE-2003-0021  (opens in a new tab)

How to fix?

Upgrade Debian:11 eterm to version 0.9.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream eterm package and not the eterm package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

The "screen dump" feature in Eterm 0.9.1 and earlier allows attackers to overwrite arbitrary files via a certain character escape sequence when it is echoed to a user's terminal, e.g. when the user views a file containing the malicious sequence.

CVSS Base Scores

version 3.1